Plumbing Question

Hi guys,

We recently had an Ideal Logic 24 combi boiler installed and have had no problems up until now. The pressure has dropped below the 0.5 mark and no matter what I try, I can't get the pressure back up. I've tried the filling loop and when I turn the valves, there is no sound of water topping up the system. We still have normal pressure water in all our taps but just none in the boiler. I've bled the rads and had no escaping air in any of them. It's like there is no supply to just the boiler. Any ideas? I can't find anything useful on the web.

Cheers in advance

Thanks for replies, we are opening both and it is one black and one blue leaver. We will try taking the hose off to check but are worried about invalidating warranty if we mess with it too much. The boiler was brand new in march - surely nothing should need replacing yet???

4 Answers

Best Answer

hi there are normally two taps on the filler loop are you opening both of them.

Answered 5th Dec 2011

woodward and sons

Member since 15 Nov 2011

Sounds like you have a blockage on the filling loop, you can try taking hose off and turning on into bucket if water flows then the check valve side, may need replacing

Answered 5th Dec 2011

Taylor Pro Plumbing

Member since 30 Dec 2010

it seems like they have put filling loop on the wrong way round

Answered 6th Dec 2011

All Seasons Plumbing

Member since 16 May 2010

Reason is not working as pressure drops it does not work what does your filling loop look like two black leavers

Answered 5th Dec 2011

Smt Plumbing & Heating

Member since 1 Dec 2010

Need help with your project?

We have tradesmen ready to help you. Post a job, read reviews and hire today.

Post a job

Need some help?

Post a job on MyBuilder to find quality, local Plumbers who can help you with your project.

Search all questions